In den letzten Tagen hat jemand zwei ziemlich umfangreiche Kommentare an einen Beitrag gehängt in dem ich mich letzten Oktober über den Vim gewundert habe. Vielleicht hat jemand mehr Zeit sich das anzusehen, deshalb antworte ich ihm mal nicht im Kommentar sondern in einem separaten Artikel.

Hallo, Peter…

Keine Ahnung warum Du mir das hier rein schreibst, ich bin kein vim-Entwickler. Ich habe im Moment auch nicht die Zeit allem nachzugehen was Du schriebst, aber nach Deinem letzten Absatz („…eines der am liederlichsten programmierten Programme… Software-Verhau… eines der am blödesten zu bedienendsten Programme…“) habe ich doch mal einen Blick auf einige Deiner Beispiele geworfen.

Meine Testdatei:

Bahnfahrer
bahnfahrer
Autofahrer
Autobusfahrer
Autobahnfahrer

Zunächst: Eine Suche mit /Auto(bahn)[0}fahrer ergibt tatsächlich nichts. Wie auch? Das ist syntaktischer Humbug. Nehmen wir an dass Du /Auto(bahn){0}fahrer meintest. Das findet bei mir (vim 7.1.267) genau den Autofahrer, und das ist meiner Meinung nach absolut richtig. Ich suche nach etwas das mit ‚Auto‘ anfängt, danach soll null mal ‚bahn‘ stehen, danach ‚fahrer‘. Das kommt genau ein mal vor. Autobusfahrer wird natürlich nicht gefunden weil in dem Ausdruck kein ‚bus‘ erlaubt wurde.

Nächster Versuch: Ich suche nach /(Bahn){0}fahrer. Nein, ich suche lieber nach /(Bahn){0}fahrer. Damit kriege ich fünf Fundstellen, nämlich jeweils das ‚fahrer‘ am Ende der Zeile. Klar, ich suche ja nicht nach kompletten Worten, sondern nur nach Stellen an denen ‚fahrer‘ steht. Meinetwegen nach Stellen an denen null mal ‚Bahn‘ steht, gefolgt von ‚fahrer‘. Ob vor dem Nicht-Auftreten von ‚Bahn‘ nicht noch ein ‚Bahn‘ stehen darf ist nicht gesagt. Ich hoffe ich konnte mich klar ausdrücken?

Von weiteren Versuchen sehe ich einfach mal ab, vielleicht hat ja jemand anderes Lust sich da durchzuquälen. Du solltest Dich vielleicht tatsächlich einfach mit Deinem Windows 98 SE und dem mitgelieferten Notepad zufrieden geben. Dazu hätte ich dann auch nochmal einen lustigen Beitrag für Dich…

Noch ein Tip am Rande: wenn Du mit einer Software rumspielst von der Du keine Ahnung hast, die aber gerade von Profis sehr gerne benutzt wird, und Du stößt dabei auf Ungereimtheiten die Du Dir nicht erklären kannst… Erst RTFM beherzigen, dann nochmal probieren. Dann im Netz nach Lösungen suchen, oder nach Leuten die die gleichen Probleme haben. Wenn das nix bringt in entsprechende Foren und Mail-Archive sehen. Ist auch das ohne Erfolg, frage an geeigneter Stelle nach. Wenn Du mit dem Problem absolut nicht leben kannst, und sich rausstellt dass das wirklich ein Bug ist der in den aktuellen Versionen noch nicht behoben ist… DANN reichst Du einen Bug-Report bei dem Projekt ein. Und zwar wirklich bei dem Projekt, nicht als Kommentar auf einen Blog-Eintrag von vor einem halben Jahr…

Ach, noch was: Danke für den Link auf Deine Homepage. Sehr aufschlussreich. :-D

Mein AquariumFertig! Abputzen!!! :-D

Das Becken steht ja schon seit einer Weile. Mittlerweile sind Fische drin und haben Spaß, ich habe die Elektrik nochmal sauber überarbeitet, die ‚obere Rückwand‘ hängt an der Wand, ist bepflanzt und beleuchtet, und auch der Wasserfall fällt tröpfelt.

Ich habe eine Menge Fotos gemacht und alles auf der Schatenseite beschrieben.

Ich bin jetzt erstmal zufrieden mit dem Ergebnis und widme mich wieder verstärkt meinem Aquariencomputer-Projekt. Der Bedarf daran ist nämlich in den letzten Tagen sprunghaft angestiegen. :-)

Oh, und hoffentlich komme ich auch wieder regelmäßiger dazu hier etwas zu schreiben. Zwei Postings im Dezember sind IMHO unbefriedigend wenig…

Hier ein paar direkte Links zu wichtigen Inhalten der Seite:

Elektronik-Projekte: